SilverFast and Mac OS X 10.5 (Leopard)
leopard_en02

In close collaboration between our developers and partners, we have succeeded in a relatively short period of time to make SilverFast compatible with the last version of the Mac OS X 10.5 for many scanners.

We work under high pressure to broaden the list of supported scanners under Leopard and will be posting new scanners on this list regularly. Every scanner undergoes a very strict testing process in our center under the new Mac OS X 10.5. Only this makes it possible for us to offer and maintain our high quality standards. Therefore, only after a scanner has passed the test we are able to release its version to the public.

Note: SilverFast is only running on Intel Macs, not on older PowerPC devices!

The SilverFast DC, HDR product families and PrinTao are Leopard compatible from version 6.5.5r2 and later.

There can be problems with older versions of SilverFast. These old versions will not be updated for Leopard. Those who want to use older versions than 6.5.5.r2 of SilverFast, should be aware that they may encounter some instability problems during the installation and usage.



SilverFast is Leopard compatible for following scanners:

Scanners with this symbol icon_15_sf6 are supported by SilverFast 6.6.
Scanners with this symbol icon_15_sf8 are supported by SilverFast 8.




Your scanner is not listed? Please download the latest Leopard-compatible scanner driver from your scanner manufacturer's website and test SilverFast before buying. For this test please choose Mac OS X 10.4 as your operating system.

For further information please have a look at our list of supported scanners.



Get your SilverFast Copy Try SilverFast Products Update your SilverFast Copy for Free
Pricing Calculator